Page MenuHomePhabricator

Rename mitk::BaseRenderer::GetTimeWorldGeometry() to GetWorldTimeGeometry()
Closed, ResolvedPublic

Description

This was probably intended, as the setter is also called SetWorldTimeGeometry().

Event Timeline

And make the parameter of the setter a const pointer, so that the return value of the getter can be passed to the setter without const cast.

And please do the same for the 3D version.

Thanks.

Thanks for these points. I will fix them as soon as possible.

We cannot set the the setter to const since they use the given object. But i created a non-const getter method to ensure setter/getter compatibility.

New remote branch pushed: bug-16292-RenamingOfTimeGeometry

I'm not sure: does this affect only very recently introduced members or has GetTimeWorldGeometry() been part of the last release? In the latter case you should talk to Sascha/Marco about deprecating the old method.

This can be easily checked by a git blame command. It tells you the commit hash, and it can be looked for in the git log.

The function which was discussed has been introduced by me during the platform change.
It became necessary since TimeGeometry does no longer inherit from Geometry3D and therefore it is not possible to return either 3D or TimeGeometry with the same interface method.

[e49610]: Merge branch 'bug-16292-RenamingOfTimeGeometry'

Merged commits:

2013-11-06 14:10:59 Michael Goetz [e96915]
Changed interface of BaseRenderer