Page MenuHomePhabricator | MITK

Multithreading within mitkPython freezes
Closed, WontfixPublic

Description

some multithreading within mitkPython freezes ... yielding an output like:

Process PoolWorker-1:
Traceback (most recent call last):

File "[...]/lib/python2.7/multiprocessing/process.py", line 249, in _bootstrap
  sys.stdin.close()

AttributeError: 'PythonQtStdInRedirect' object has no attribute 'close'
Process PoolWorker-2:
Traceback (most recent call last):

File "[...]/lib/python2.7/multiprocessing/process.py", line 249, in _bootstrap
  sys.stdin.close()

AttributeError: 'PythonQtStdInRedirect' object has no attribute 'close'

this does not always occur - my best guess is that it is caused by multiple threads in turn starting threads ... outside MITK this works, though

Event Timeline

kislinsk closed this task as Wontfix.Jun 20 2018, 6:25 AM
kislinsk claimed this task.
kislinsk added a subscriber: kislinsk.
This task was automatically closed because it wasn't updated at least since July 2016 (over 2 years). Please re-open this task if you think that it is still relevant. This most probably means that you will resolve it.