Page MenuHomePhabricator

MitkQtPythonTest fails because of missing library dependencies on Linux
Closed, ResolvedPublic

Description

jenkins@mbi086:~/jenkins-agent/workspace/MITK/Nightly/Linux/build/MITK-build$ ldd ../ep/src/CTK-build/CMakeExternals/Install/lib/libPythonQt.so
        linux-vdso.so.1 (0x00007fffec5f5000)
        libpython3.6m.so.1.0 => /usr/lib/x86_64-linux-gnu/libpython3.6m.so.1.0 (0x00007f429868b000)
        libQt5Widgets.so.5 => not found
        libQt5Gui.so.5 => not found
        libQt5Core.so.5 => not found
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4298302000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4297f64000)
        ...

libPythonQt does not link Qt dependencies with absolute path on Linux.

Event Timeline

kislinsk triaged this task as Normal priority.Jan 7 2020, 12:52 PM
kislinsk created this task.
nolden added a subscriber: nolden.Jan 7 2020, 4:17 PM
kislinsk closed this task as Resolved.Jan 7 2020, 4:33 PM
nolden added a comment.Jan 7 2020, 5:45 PM

I can confirm this works. One downside I realized with the current solution is that it only works if the test is executed through ctest, i.e. ctest -R Pytohn , but if you start the driver directly the same problem occurs. I think it is ok for now, but would be some motivation to find a solution that works without a special environment, since for example while debugging you usually start the executable directly.