Page MenuHomePhabricator

[MPI] mpi4py dependency breaks ReadTheDocs builds
Open, NormalPublic

Description

Since mpi4py is a main dependency ReadTheDocs does not work anymore as the RTD container does not have the mpi linux libs installed and the installation of mpi4py fails.

Either we need a dedicated build image for RTD that has the libs installed or we must make the mpi4py dependency optional and deactivate it when building the docs.

Event Timeline

floca triaged this task as Normal priority.Wed, Feb 10, 10:03 PM
floca created this task.