Page MenuHomePhabricator

Different style for frequency definition in the parameter space definition (for grid search and alike)
Closed, ResolvedPublic


I would propose that we do not specify the frequency as third value in the data array (see current hyppopy documentation).

Instead I think it is better to define an additional optional aspect (e.g. "frequency"). Solvers can then be look for this information if the need it or can interpret it. If the information is not given, the solver can print a warning and use a default value (like solvers do with missing iteration information) or raise a runtime exception.

Old style for gridsearch would be:

"myParam": {
    "domain": "uniform",
    "data": [0, 100, 10],
    "type": "float"

I would propose:

"myParam": {
    "domain": "uniform",
    "data": [0, 100],
    "type": "float",
    "frequency": 10

Reason: The new style would better explicitly express the role of each value. In the old style it is just definied by policy (You have to know where to put the information).