I find the name of VirtualFunction missleading. I for example first thought of something general (polymorphic) from the software dev domaine.
As it is a mock up energy/loss function, I propose to call it as such. The would minimize confusion and help to directly grasps the purpose.
So something like MockUpEnergyFunction or TestEnergyFunction.