Page MenuHomePhabricator | MITK

Three views not displayed on MITK Tutorial Steps 4-7
Closed, ResolvedPublic

Description

When running Steps 4 to 7, only the two 2D views for slicing through the data are displayed, and not the 3D view.
Might be solved specifying the "Stretch" parameter when adding the widgets to the layout:

layout.addWidget(&renderWindow, **1**);

It was tested in the MITK master branch #647640c36bcc` using VS2015 x64 and x32 on a Windows 10 system.

Event Timeline

aguilera created this task.Feb 7 2018, 2:02 PM
aguilera triaged this task as Normal priority.
aguilera renamed this task from Three views not displayed on MITK Tutorial Step 4-7 to Three views not displayed on MITK Tutorial Steps 4-7.
kahl added a subscriber: kahl.Apr 5 2018, 2:11 PM

The problem is that in qt, the minimum size of a render window is defined as width=-1 and height=-1 while for slice widgets it's width=~50 and height=79.
You can see this when calling the function

renderWindow.minimumSizeHint();

(view2.minimumSizeHint() etc.) after adding each window

goch closed this task as Resolved.Apr 13 2018, 11:01 AM
goch claimed this task.