Page MenuHomePhabricator | MITK

Ultrasound persistence is disturbed by QFileDialog::getOpenFileName
Closed, InvalidPublic

Description

Open Plugin-view "Ultrasound Support"
--> Remove all available ultrasound devices
--> Click "New Video Device"
--> Click "Add Video Device"
--> Click "Activate" then click "Deactivate"

Open Plugin-view "IGT Navigation Tool Manager"
--> Click on "Load"-Button next to "Whole Storage"
--> Cancel opened file dialog.
--> Close MitkWorkbench

--> Start MitkWorkbench again
--> Open Plugin-view "Ultrasound Support"

--> The last created ultrasound video device is not available due to the disturbed ultrasound persistence.

Related Objects

Event Timeline

mittmann triaged this task as Normal priority.Apr 12 2018, 6:21 PM
mittmann created this task.
yoganath added a comment.EditedApr 13 2018, 11:01 AM

We tried to reproduce this behaviour with the current state of T24059-IGTRelease-2018.03 branch under Windows with a 32-Bit Build. We followed the above mentioned steps, the last created ultrasound device is still visible in the ultrasound plugin.
@mittmann Could you specify on which branch you found this error?

mittmann added a comment.EditedApr 14 2018, 10:29 AM

I still cann detect the disturbed ultrasound persistence in the current state of branch T24059-IGTRelease-2018.03 (state: 14.04.2018, 10 am). I am using a Windows 64-Bit build under VisualStudio 2017. How should we proceed?

Perhaps it is a QT-related bug. I am using Qt5.7.1 msvc2013_64.

I was not able to reproduce that issue either. My configuration:

  • IGTRelease-2018.03 (16.04.2018, 9:30 am)
  • Visual Studio 2015 32 bit build
  • Qt5.6 msvc2015

Even when applying /Blueberry.clean to always start with a clean workbench the US persistence is working.

@sridhara Which Qt version did you use when you tested it? Could you also try to build a clean 64 bit version and check if the problem occurs? Thanks!

@mittmann The compiler used to create your Qt binaries (VS 2013) doesn't fit the compiler you use to build MITK (VS 2017). Could that be a problem?

On Friday we used:

  • Visual Studio 2015
  • Qt 5.7.1 msvc2015
sridhara moved this task from Backlog to In Progress on the IGT board.Apr 16 2018, 2:10 PM
seitela closed this task as Invalid.Apr 27 2018, 3:31 PM

Bug cannot be reproduced anymore