Currently the naming of DICOM related modules is inconsistence (e.g. in upper case / lower case):
- DicomRTIO (autoload module)
Following things should be regarded:
- We should either choose "DICOM" or "Dicom" but should not mix both
- I would propose to rename DICOMReader to have a wider scope that includes also writer, because they will come sooner or later (sooner If i look at the requests). E.g.:
- DICOMImageIO (because at its heart it covers only Image IODs or derived stuff)
- I would propose to rename DICOMRT into RT (and rename its autoload module into DICOMRTIO). The Reason is that the module itself has nothing to do with DICOM but with data structures and mappers for RT data. Only the autoload module has something to do with io at all. DICOMRT itself is the partner of RTUI and that should be resembled in its naming like we do with other modules.