Page MenuHomePhabricator

[Perfusion] - Problems selecting T1 map
Closed, ResolvedPublic

Description

Problem: For the Signal to Concentration Conversion via the T1 map, MITK requires the T1 map but in the drop down menu we can only select the DCE DICOM images (dynamic/dynamic, please see attachment).
We have also tried to upload the T1 map in NiFti format, but unsuccesfully.
Could you please help us in figuring out the correct input parameters needed for the analysis?

Event Timeline

floca triaged this task as Normal priority.Jan 19 2020, 8:30 AM
floca created this task.
floca closed this task as Invalid.Jan 19 2020, 8:36 AM

The problem was caused by the fact that the T1 map has just 2 different pixel values. Therfore it was automatically classified as binary image /mask on loading.

Solutions:

  1. Either ensure that the T1 map image has more then 2 values
  2. Or change the properties of the data node:
    1. Select the node
    2. Open the "Property view"
    3. Uncheck the property "binary"
    4. now the map can be selected.
Sara added a subscriber: Sara.Jan 20 2020, 11:04 AM
This comment was removed by Sara.
Sara added a comment.Jan 20 2020, 11:08 AM

Hi Ralf,
We changed the properties of the data node regarding the T1 map but unsuccessfully.
We always get "Dimension 2 is not in (ItkOutputImageType::ImageDimension)" error.
We also checked the dimensionality of the T1 map from the Details Menu:

Dimension: 2
Dimensions: 60 200

The simulated DICOM data come from the QIBA dataset.
The T1 map in nifti format was obtained from the Variable Flip Angle simulated data that comes along with the QIBA dataset.
We computed the T1 map using ROCKETSHIP.
Thank you,
Sara and Daisy.

In T27006#191923, @Sara wrote:

Hi Ralf,
We changed the properties of the data node regarding the T1 map but unsuccessfully.
We always get "Dimension 2 is not in (ItkOutputImageType::ImageDimension)" error.

Just to be sure. The work-arround with the "binary" property (see above) is only for the problem that you weren't able to select the T1 map in the view.
It is not a solution for the Dimension 2 is not in (ItkOutputImageType::ImageDimension) error!

We also checked the dimensionality of the T1 map from the Details Menu:

Dimension: 2
Dimensions: 60 200

The simulated DICOM data come from the QIBA dataset.

OK. So I can reproduce your problem by just loading the QIBA dcm data you send me. Right? If I use it with our perfusion view, I should see the error above.

I think the problem rises form the fact that the data is loaded in 2D (instead of 3D with just one slice) into the worbench (I thought it always loads as 3D) and some of the filter pipelines in the views are assuming images that are either 3D or 3D+t.
I have to check it out.

Sara added a comment.Jan 20 2020, 12:49 PM

Hi Ralf,
to make it clear, for the Signal to Concentration Conversion via the T1 map, MITK required the T1 map but in the drop down menu we could only select the DCE DICOM images.
We tried to fix the problem in two ways:

  • Editing the T1 map to have more than two values otherwise MITK would recognized it as a mask.
  • Uncecking binary property of the data node for the T1 map.

In the first case, we are able to select the T1 map in the drop menu, but we get the Dimension 2 is not in (ItkOutputImageType::ImageDimension) error.
In the secon case, we are still not able to select the T1 map in the drop menu.

Yes, you can download the data from link we sent you.
Thank you for your help,
Sara and Daisy

floca reopened this task as Open.Jan 29 2020, 9:21 PM

I started to look into it with help of the QUIBA data.

Following remarks:

  1. I used only the dicom data, as I don't no the format of "xml"
  2. Thus I could not check/reproduce why your manipulated nifti approach is loaded as 2D image (which is the problem in "solution 1").

Result: I could make it work with the QIBA dcm data sets (and solution 2: uncheck binary property), but the following thinks must be considered.

  1. The T1map ComobBox widget has a bug, it does not update if a node property is changed. A work arround is to change the property before you open the MR Perfusion view. Then the data can be selected. We are currently in the process of refactoring the selection concepts. As soon as T27043 is done. This problem will be gone.
  2. T1 map is only supported as 3D image. If one loads directly from the QIBA directory layout, all fa*.dcm files will be loaded as on 3D+t image (this is because all images have the same series instance but different timing, thus MITK assumes it is 3D+t). To circumvent this.. You have to put the map you want to load in its own directory. Then it is loaded as just one 3D image.

Does it work for you?

Sara added a comment.Jan 30 2020, 12:39 PM

Hi Ralf,

thank you for you reply.

We would like to highlight that the fa*.dcm files are the Variable Flip Angle simulated acquisitions that one has to fit in order to compute the T1 map.
The workaround to change the property before you open the MR Perfusion view works, but the problem is the dimension of the map which is in 2D.

Kind regards,
Sara and Daisy

floca added a comment.Jan 30 2020, 1:25 PM
In T27006#193592, @Sara wrote:

We would like to highlight that the fa*.dcm files are the Variable Flip Angle simulated acquisitions that one has to fit in order to compute the T1 map.

Ah ok. Thanks for the clarification.

Could you then provide me the T1 map you have computed (which is 2D). Or did you use our fitting infrastructure and the T1 model?

Sara added a comment.Jan 30 2020, 2:33 PM

Hi Ralf,
please find enclosed the T1 map obtained from ROCKETSHIP.
Kind regards,
Sara and Daisy

floca closed this task as Resolved.Feb 13 2020, 9:38 PM
floca claimed this task.
floca added a subscriber: kompan.

I close this task for now. Reason:

  • The problem of selecting a T1 map was identified. There is a workarround (see above) and it will be finally covered by T27043.
  • The fact that the current T1 conversion can be missunderstood is covered by T27047.
  • Adding an additional conversion option will be discussed by @Sara and @kompan and may spawn new tasks.