Workbench crashes when creating a new tool storage
Closed, ResolvedPublic

Description

Creating a new tool storage in the 'IGT Navigation Tool Manager' view leads to a crash when 'IGT Navigation Tool Calibration' view has been closed before.

Steps to reproduce:

  • Start workbench
  • Open 'IGT Navigation Tool Calibration' view
  • Open 'IGT Navigation Tool Manager' view
  • Close 'IGT Navigation Tool Calibration'
  • Click 'Create New' button in 'IGT Navigation Tool Manager' view
  • Fill in a name
  • Click 'OK'

--> Workbench crashes

eisenman created this task.Nov 17 2017, 5:53 PM
eisenman added a project: MITK.
eisenman updated the task description. (Show Details)
franza moved this task from Backlog to 2018 - Release relevant on the IGT board.Jan 12 2018, 10:54 AM
seitela claimed this task.

This crash also occurs when using the TrackingToolBox plugin instead of the NavigationToolCalibration plugin. It seems to be related to the QmitkToolTrackingStatusWidget where a call to 'OnServiceEvent()' is triggered by the micro service framework. A non properly initialized m_previewToolStorage leads to the crash.

seitela moved this task from In Progress to Finished on the IGT board.Jan 30 2018, 2:05 PM
seitela closed this task as Resolved.Apr 20 2018, 8:30 AM