With https://phabricator.mitk.org/rMITK8bda195730158693fd56a0707d67d820037f1655 there was a change in behavior of the DataStorageTreeModel.
After this commit the name of the node is ignored/overwritten, if there are DICOM properties stored. In the later case a node name is generated out of the DICOM properties.
I have the following concerns with this code:
- As soon as you have DICOM properties, you cannot control how the node should be named in the data manager.
- The naming of nodes in Datamanager and other parts of the workbench diverge. Other plugins use DataNode::GetName() and will get/show something else. Not good.
There is good reasoning for central logic for node naming (and we also have tasks asking for a more intelligent naming), but in the DataStorage it is the wrong place.
So I would propose to revert the commit in such a way, that the data storage displays the node name (DataNode::GetName()) again.
Strategies to generate proper naming should be hidden beyond this iterface (or another globally available interface (e.g. simelar to property aliases)).