Page MenuHomePhabricator | MITK

Difference between GUI and expected values MitkImageStatisticsCalculatorTests
Closed, ResolvedPublic

Description

Different results if one runs GUI and uses ImageStatisticsCalculator with the same input data

  • TestUS4DCylAxialPlanarFigureMaskStatistics_time1
MITK VersionEntropyKurtosisMPPmaxmean
2016.11 GUI6.17781.587115.45199115.45
2018.04 GUI6.17781.587115.45199115.45
Test (since f94aca1d1637, 2 years ago)6.21811.732121.12199121.18

Expected test values same than GUI (2016.11/2018.04 new image statistics plugin)

  • TestPic3DStatistics
  • TestPic3DAxialPlanarFigureMaskStatistics
  • TestPic3DImageMaskStatistics_label1
  • TestPic3DIgnorePixelValueMaskStatistics
  • TestUS4DCylStatistics_time1
  • TestUS4DCylIgnorePixelValueMaskStatistics_time1

Not testable

  • TestUS4DCylImageMaskStatistics_time1_label_1
    • because label can't be set in GUI

Event Timeline

hentsch created this task.Nov 30 2018, 4:23 PM
hentsch triaged this task as Normal priority.
floca added a project: Restricted Project.Nov 30 2018, 9:18 PM
floca moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Nov 30 2018, 9:20 PM
floca raised the priority of this task from Normal to Needs Triage.

Unexplained differences make me nervous. We should at least discuss in the next stand up how critical it is and how we prioritize it. I have the guts feeling that it should get a higher priority.

hentsch renamed this task from Are MitkImageStatisticsCalculatorTests correct? to Difference between GUI and expected values MitkImageStatisticsCalculatorTests.Dec 4 2018, 3:46 PM
hentsch updated the task description. (Show Details)
floca triaged this task as Unbreak Now! priority.Dec 5 2018, 10:58 AM

For clarification of the reason

hentsch claimed this task.Dec 5 2018, 11:06 AM
hentsch updated the task description. (Show Details)Dec 5 2018, 11:57 AM
hentsch updated the task description. (Show Details)
hentsch updated the task description. (Show Details)Dec 5 2018, 2:12 PM
hentsch removed hentsch as the assignee of this task.Jan 18 2019, 8:17 AM

Looking at the code I didn´t see the results of the GUI differing from the expected values of the test, maybe you looked at the wrong timestep because your GUI data matches with timestep 0.
Setting the US4D label1 is possible right now, but the GUI fails at label2.
But there are still results not matching up:
TestPic3DImageMaskStatistics_label2´s expected results and GUI data don´t add up.

hentsch added a comment.EditedThu, Feb 7, 1:05 PM

I checked TestPic3DImageMaskStatistics_label2 and TestUS4DCylImageMaskStatistics_time1_label_2 via code changes (not possible via GUI). The values are consistent between test and GUI.
I can confirm that in TestUS4DCylAxialPlanarFigureMaskStatistics_time1 everything is the same too (see T24653)

floca added a comment.Thu, Feb 7, 1:29 PM

@hentsch So does that mean it was false alarm or do I missinterpret something?

Only the old statistics plugin was affected. In the new plugin, all is ok.

floca added a comment.Thu, Feb 7, 1:39 PM

Hail to the new statistics plugin! One more reason why your epic effort was well invested 😄

hentsch closed this task as Resolved.Thu, Feb 7, 3:03 PM
hentsch claimed this task.
floca moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Wed, Feb 13, 10:46 AM