Page MenuHomePhabricator

scrolling in a 2d render window scrolls simultaneously in all three directions
Closed, ResolvedPublic

Description

... happens after the latest T24215 related merge

Event Timeline

kirchnth triaged this task as High priority.Nov 6 2019, 2:29 PM
kirchnth created this task.

note that I did not use a clean build

also occurs in clean build - in addition: opening the Workbench for the first time after build causes a crash

kalali added a comment.EditedNov 13 2019, 11:57 AM

I remember having seen this error but I thought I fixed it. Currently, I cannot reproduce it, using the latest master 8a6a7a85.
Could you give a precise description of the steps to take in order to reproduce this bug?

Or maybe I misunderstood you, because when we were talking about that problem face-to-face you said something about the crosshair moving into on of the corners while scrolling with the mouse wheel or the like?

Edit: We clarified it, I did not udnerstand it correctly. I see the problem now!

So if you just want to use the new multi widget with different images and navigation de-synchronized, just disable navigation synchronization by hitting the toolbar button with the two arrows on the right side of the multi widget.

This fixes the problem but another problem arises, which is due to the use of the DisplayActionEventFunctions and the implementation inside QmitkAbstractMultiWidget:
A widget can either have a synchronized or a de-synchronized interaction. However, in the case of the StdMultiWidget all interactions are de-synchronized, except for the SetCrosshair-action. So in the StdMultiWidget-case we have to handle the action events differently.

kalali added a comment.EditedNov 14 2019, 6:12 PM

Should be fixed now. Different multi widgets use different action event handler.

Edit: Wait for D220

kalali closed this task as Resolved.Nov 29 2019, 1:58 PM