Page MenuHomePhabricator | MITK

[image statistics plugin] 4D image + 4D segmentation as mask does not work
Closed, ResolvedPublic

Description

  • load 4D image
  • create 4D segmentation with plugin
  • open image statistics plugin and select image and segmentation

It only works under the condition that each timestep is non-empty, i.e. has a masked pixel.
Otherwise, MITK crashes.

Related Objects

StatusAssignedTask
Resolvedkausch

Event Timeline

hentsch created this task.Feb 12 2019, 2:25 PM
hentsch triaged this task as Normal priority.
hentsch added a subscriber: kausch.Apr 12 2019, 9:35 AM

Statistics are calculated for those time steps where a mask is provided, for the others not. When the view asks for the statistics an exception is thrown if the statistics don't exist.

see: QmitkImageStatisticsCalculator, line 209ff (Histogram visualization)

We put a try catch around that . There seems to be another exception thrown when willing the table view. The statistics table is not filled:

kausch added a comment.EditedApr 26 2019, 11:39 AM

Solution: GetStatisticsForTimeStep method now returns an empty StatisticsObject if no mask is provided for this time step. Thus, histogram and table are empty for those time steps.
Discussion: 1. 4D image + 3D segmentation

  1. 4D image (5 time steps) + 4D segmentation (1 time step)

@hentsch Is the one time step segmentation applied to all time steps? What is the expected behavior?

floca added a comment.Apr 26 2019, 1:18 PM

I have concerns with the latest commit. See comments there. You can come by and ask if you have any questions.

kalali added a subscriber: kalali.May 3 2019, 1:47 PM

@hentsch Is the one time step segmentation applied to all time steps? What is the expected behavior?

Yes. One segmentation timestep to rule all image timesteps! But the last time I tested it, it worked fine.

@kausch @kleina you resolved this task, right?
If not done already, please merge to the master.

Yeah, we did... to be honest, I don't know if it is merged yet. @kausch can you please check this?

I merged it, we only pushed the branch

floca added a comment.Wed, May 29, 9:31 PM

I merged it, we only pushed the branch

@kausch You have not closed the task ;). Was this task done in its own branch or as a "side" task in an other branch?

kausch closed this task as Resolved.Mon, Jun 3, 9:18 AM
kausch claimed this task.

@floca This is the branch T26029-4DImageAnd4DSegmentation