The name if the fill tool is missleading. To many people (including me and others of the team) thought it is like gimp/photoshop fill. Which is not. It is more a interactive closing operation (with a very large step size).
The proposal is to rename the tool and use another icon to reflect that better. e.g. Closing tool.
- Clarify if the tool should be renamed
- Clarify if we want to introduce are real fill tool (would mean a new task)
- Act accordingly
Remark: The close operation is also possible based on the FillRegionBaseTool. Reimplement tool this way. This also allows to depricate and remove the SetRegionTool class.