Contour broken for 3D and 2D interpolation in multilabel segmentation plugin
Open, HighPublic

Description

If you try to use 3D or 2D interpolation with any segmentation plugin, the green contour is missing and as a consequence interpolation doesn't work at all.

thomass created this task.Oct 17 2016, 4:21 PM
thomass renamed this task from Contour broken for 3D and 2D interpolation in classic/multilable segmentation plugin to Contour broken for 3D and 2D interpolation in classic/multilabel segmentation plugin .
kalali added a subscriber: kalali.Oct 17 2016, 5:01 PM
goch added a comment.Oct 17 2016, 5:57 PM

It seems this only happens if the multilabel plugin is active. If I start the workbench with only the segmentation plugin itself active it works.

heime claimed this task.Oct 28 2016, 1:51 PM

Is this still valid? I couldn't reproduce this. However, I noticed that there is no contour for the 3D interpolation in the multi-label case (regardless of the classic segmentation plugin being open or not).
If not, I propose to close this task and open another one for a more specific description of current contour / interpolation bugs.

To clarify: The 2D- and 3D-Contour of the interpolation, using the classic segmentation plugin still works (2D contour in yellow, 3D contour in green).
But, as stated above, no contour is shown for the 2D- and 3D-Contour of the interpolation, using the multi-label segmentation.

kalali renamed this task from Contour broken for 3D and 2D interpolation in classic/multilabel segmentation plugin to Contour broken for 3D and 2D interpolation in multilabel segmentation plugin .Aug 18 2017, 2:52 PM

Unrealistic to be solved for the upcoming demo. This will require some preparatory design decisions, such as which labels/layers to show contours for.