Page MenuHomePhabricator | MITK

re-init does not work with images with flipped axes
Closed, InvalidPublic

Description

After doing re-init on an image with flipped axial and coronal axes, the windows go blank.

Event Timeline

espak created this task.Nov 15 2016, 8:34 PM
hettich added a subscriber: hettich.Dec 5 2016, 8:23 AM

cannot reproduce.
awaiting example data file and exact specification of affected version.

hettich claimed this task.Dec 5 2016, 11:20 AM
espak added a comment.Dec 5 2016, 12:13 PM

Here are some:





Try the first one, it does not show up neither after global reinit, nor after reinit.

Commit:
8d4c322

Screenshot:

espak added a comment.Dec 5 2016, 2:10 PM

Actually, this might fail also because the nifti reader in MITK (ITK) is broken. We are using a patched nifti reader.

I was testing this also in our application that has the fixed nifti reader and it has the MITK display and the images with flipped axes did not display. But that was using our MITK fork that still has 2015.05.2 + patches.

I will generate test images in nrrd format and test again.

kislinsk claimed this task.Dec 5 2016, 2:40 PM
kislinsk added a subscriber: kislinsk.

Great, thank you. I will really help us when you provide nrrd test data. I'll have a look at T22113 meanwhile.

espak added a comment.Dec 5 2016, 5:24 PM

We have a utility to generate 3D test images with check pattern with any rotation matrix but it cannot save nrrd because the nrrd writer service is in DiffusionIO and we disabled the diffusion stuff because we do not really need it. I am trying to enable it but it has so many dependencies (even in ITK and VTK) that it is not easy. By the way, would you guys accept a PR for moving the nrrd writer service to MitkIOExt?

hettich triaged this task as High priority.Dec 5 2016, 5:32 PM

Seems to work now in master, commit bfcf1f07676058b32bee39f295ea1019013943ec

Mr Miklos Espak, would you kindly reconfirm or refute this?

espak added a comment.Dec 5 2016, 5:42 PM

Is it the nifti image or it was converted to nrrd?
If nrrd, would you mind attaching it to this task if it is not too much of a hassle?

espak added a comment.Dec 5 2016, 6:23 PM

I get the same blank windows when opening the nifties with bfcf1f07676058b32bee39f295ea1019013943ec.
I did a superbuild and deleted the plugin cache.

espak added a comment.Dec 5 2016, 8:30 PM

I made a clean build on linux and mac of the latest master. On linux my test images are displayed correctly, both after re-init and global re-init. I tried images with flipped, permuted and rotated axes, they all looked fine.

On mac none of the images appear at all, not even regular ones. But this must be an unrelated issue.

Thank you for checking.

espak closed this task as Invalid.Dec 5 2016, 8:31 PM
espak added a comment.Dec 12 2016, 6:22 PM

Just for the record. I closed PR160 and pushed an almost identical pull request for T22254.

PR172. (Branch name changed to refer to the new task and 'None' orientation handled in the same was as 'Axial'.)