Page MenuHomePhabricator

Image navigator time slider moves twice
Closed, WontfixPublic

Description

You have to press the up or down buttons really quickly or it will count it as two (or sometimes more) steps.
We think this is due to the functionality of holding one of the buttons to keep sliding and the timeout between two steps seems too short.

Event Timeline

jungsi created this task.Jul 6 2018, 1:38 PM

Could you please provide a data set in order to reproduce this bug (maybe from MITK-Data)?

jungsi added a comment.Jul 9 2018, 9:26 AM

Of course, steps to reproduce:

  • Load MITK-Data\3D+t-ITKIO-TestData\LinearModel_4D_arbitrary_time_geometry.nrrd
  • Doing a normal press should now step 2 time steps at once
  • Doing a really short press should allow you to single step

One more thing to try:

  • Start MITK in Debug configuration
  • Load MITK-Data\Pic2DplusT.nrrd
  • Stepping should work fine
  • Set a breakpoint on QmitkImageStatisticsReloadedView::OnTimeChanged
  • Stepping once should now always trigger the event twice (and the slider gets moved two steps as well)

Should also have mentioned that I tested this on branch T24182-newImageStatisticsPlugin.
Im building the master atm so I'll report if it has the same result

jungsi added a comment.Jul 9 2018, 3:34 PM

Using the most recent master on my laptop (my pc build failed) I couldn't reliably reproduce the issue.
Maybe it's specific to the imageStatistics branch or my machine.

floca added a subscriber: floca.Jul 10 2018, 10:38 AM
kislinsk triaged this task as Low priority.Nov 22 2018, 11:43 AM
kislinsk added a project: Restricted Project.
kalali added a subscriber: kalali.Aug 16 2019, 11:32 AM
kalali added a comment.EditedAug 16 2019, 1:41 PM

See T24766.
I also experienced the two-step when debugging but using only console-output this does not happen with other time-data than 3D+t-Heart.

Edit: It happens (e.g. with MITK-Data/3D+t-ITKIO-TestData) only if the 3D+t-Heart data is also loaded and visible.

kalali raised the priority of this task from Low to Normal.Mon, Jun 22, 1:18 PM
kalali edited projects, added MITK (2020); removed Restricted Project, MITK.
floca closed this task as Wontfix.Sat, Jun 27, 1:19 PM
floca claimed this task.

This is due to the Autorepeat feature of the SpinBox up and down buttons (which allow to just keep the btn widget press and produce several clicks).
This feature can lead to problems, if you make to time consuming computations in your slot function, that is triggered by the value change, and therefor the button release event comes to late, the auto repeat kicks in.
So debug mode and especially break points often produce false positives. They should be ignored. It is only important if you can observe/reproduce this problem in release mode. I was not able to do so with ~10 dynamic images in one session at once.

I will close this task for now. If we have this manifests in release mode, we either have to raise the auto repeat delay/interval or must move the payload to another thread.