Page MenuHomePhabricator

[Segmentation] Crash using Watershed on different time steps
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Start MITK Workbench and load a 4D image (i.e. US4DCyl.nrrd)
  2. Start the segmentation plugin
  3. Create a new segmentation
  4. Use Watershed (3D tools) on the segmentation
  5. Create a second segmentation
  6. Change the time step
  7. Use Watershed on the second segmentation

The progress bar shows, reaches 100 percent and then the Workbench crashes

tested on Windows 10

Event Timeline

kraeuter created this task.Jan 9 2019, 8:56 AM
kislinsk triaged this task as Normal priority.Jan 9 2019, 12:17 PM
floca edited projects, added MITK (2020); removed MITK.May 22 2020, 1:59 PM
floca moved this task from Backlog to Segmentation on the MITK (2020) board.
thomass added a subscriber: thomass.EditedJun 10 2020, 9:45 AM
  • Works for dynamic (4D) segmentations but creates the same segmentation for all timesteps
  • Could not be reproduced for static segmentations since the workbench crashes during the creation of a static segmentation (related to T27476)
kalali renamed this task from [Segmentation]Crash using Watershed on different time steps to [Segmentation] Crash using Watershed on different time steps.Jun 12 2020, 12:14 PM
floca added a subscriber: floca.

Please check if problem still persists as soon as T27490 is merged into develop or directly with D329 (is open for review by the way ;)

kalali added a subscriber: kalali.Jun 25 2020, 12:51 PM
  • Works for dynamic (4D) segmentations but creates the same segmentation for all timesteps
  • Could not be reproduced for static segmentations since the workbench crashes during the creation of a static segmentation (related to T27476)

I am now able to create a static segmentation on a 4D image. Watershed creates the same segmentation for all timesteps (because the 3D segmentation is valid for each timestep).

But the 3d segmentation has only 1 timestep with duration = sum of durations of all 4D image timesteps, right?

Yes. I think this is more related to your other discussion in T26974: "What to do with a 3D segmentation of a 4D image."

floca added a comment.Jun 25 2020, 1:53 PM

But the 3d segmentation has only 1 timestep with duration = sum of durations of all 4D image timesteps, right?

On should really seperate between bugfixes (e,g, crashes like the here mentioned) and the discussion "what does it mean to make a 3D segmentation on a 4D image" (which is more like a feature discussion).

So I would propose to focuse here on the crash and have anoter task with RequestForDiscussion on the other topic.

kalali closed this task as Resolved.Jul 2 2020, 9:58 AM
kalali claimed this task.
kalali removed a project: Missing Info.

Can not be reproduced.