Page MenuHomePhabricator

[Segmentation] Fast Marching 3D Tool only supported for first time step in 4D images
Open, HighPublic

Description

Other time steps cannot be segmented.

To reproduce:

  1. open 4D image (e.g. US4DCyl.nrrd)
  2. create a new static segmentation mask
  3. change the time step to t != 0
  4. set a seed point using the Fast Marching 3D segmentation tool
  5. see how the green contour is places nowhere close the seed point

Revisions and Commits

Event Timeline

kislinsk closed this task as Wontfix.Jun 20 2018, 6:25 AM
kislinsk claimed this task.
kislinsk added a subscriber: kislinsk.
This task was automatically closed because it wasn't updated at least since July 2016 (over 2 years). Please re-open this task if you think that it is still relevant. This most probably means that you will resolve it.
kalali renamed this task from Fast Marching 3D Tool only supported for first time step in 4D images to [Segmentation] Fast Marching 3D Tool only supported for first time step in 4D images.Wed, Jul 29, 2:08 PM
kalali reopened this task as Open.
kalali removed kislinsk as the assignee of this task.
kalali updated the task description. (Show Details)
kalali edited projects, added MITK (2020); removed MITK.
floca raised the priority of this task from Normal to High.Tue, Aug 4, 8:45 PM
floca moved this task from Backlog to Segmentation on the MITK (2020) board.
floca claimed this task.Tue, Aug 4, 8:56 PM
floca added a revision: Restricted Differential Revision.Thu, Aug 6, 9:08 PM
thomass added a subscriber: thomass.Fri, Aug 7, 1:12 PM

I also experience a crash in the tool:

  • Open US4DCyl.nrrd
  • Use 2D Segmentation tool on timestep =0
  • Change timestep = 2
  • Open FastMarching --> Crash!!

@floca Maybe you have an instant idea since you are working on it atm. Otherwise I create a new task for it.

floca added a comment.Fri, Aug 7, 8:43 PM

Did you experience the error based on the Differential? Did you open FastMarching for 2D or 3D?

Oh I didn’t look into the Differential yet, only tried it with the current develop. The crash I observed in with FastMarching3D

floca added a comment.EditedFri, Aug 7, 8:51 PM

Oh I didn’t look into the Differential yet, only tried it with the current develop. The crash I observed in with FastMarching3D

Ok, then I will spare the time and make no assumptionss or guesses as D380 has made an major rework of FastMarching3D. 😉