The different view planes / view modes are used at many different locations. It might make sense to move them to a single specific location to have a consistent naming and to allow the use of this enums as arguments for different functions.
Where such enums are defined:
QmitkRenderWindowMenu.h(has been removed in dd6d221ed26b)- mitkPlaneGeometry.h
QmitkStdMultiWidget.h(has been moved to mitkBaseRenderer.h in a0b88fbab45c)- mitkSliceNavigationController.h
- mitkNavigationDataSliceVisualization.h (kind of)
- mitkCLUtil.h (kind of)
Remove the ViewDirection enum from the BaseRenderer
and use the new AnatomicalPlane enum class for the
different directions / planes.
Remove the ViewDirection enum from the SliceNavigationController
and use the new AnatomicalPlane enum class for the
different directions / planes.
Remove the PlaneOrientation enum from the PlaneGeometry
and use the new AnatomicalPlane enum class for the
different orientations / planes.
Migration should be easy, since the different directions / planes /
orientations are the same and in the same order as before.
"ViewDirection::THREE_D" is now "AnatomicalPlane::Original".
"PlaneOrientation::None" is now "AnatomicalPlane::Original".